Date Issue Reported: 12/18/2024
Resolution Phase: Open
Issue: SCORESF-1159
Duplicate emails are being sent from Zoom during event registration. Instead of a single confirmation email, registrants are receiving multiple (often three) emails for the same event.
Cause:
Testing on 08/28/2024 after upgrading the Heroku Postgres database revealed that this issue is likely due to the application making multiple POST calls to Zoom’s API for a single registration. This may be caused by multiple containers on the server processing the same request at the same time.
Solution Required:
- Investigate and identify why Zoom emails are being sent multiple times.
- Ensure that only one email is sent for each event registration by limiting API calls to one per registrant.
We appreciate your patience and If you have any further questions or encounter additional issues, please reach out to our support team for assistance.
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